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Using the Image File Generator Software. 
 
The scan angle and efficiency of a beam-steered AO deflector depends on the frequency, amplitude, 
and phase of the RF driver signal. The scan angle is determined by the frequency. For a beam steered 
AO deflector (these have 2 or more RF inputs per axis) the phase between the RF inputs must be set 
correctly for optimum efficiency. The phase value depends on the frequency, wavelength and the 
AO design.  For simplicity, the AO design factors are described by a single figure “AOD Geometric 
Phase Constant”. This figure is provided with the each model. The amplitude value controls the 
intensity of the scanned laser beam.  
 
The iHHS-4 synthesizer can store up to 1 million points. Each point contains frequency, amplitude, 
and phase data.  A set of points is called an Image.  For an X-Y scanner, the Image(s) can be a circle 
or square outline, spiral, solid shape, a single point etc.  Many images can be programmed, 
downloaded and then output as required. 
 
We supply a Windows program “ImageFileGenerator (version 1.2.0.12) “. This program enables 
Images to be generated or imported. It takes real “MHz” frequency values and converts them into 
the data format required by the DDS synthesizer within the iHHS-4. This software then calculates the 
correct phase value and amplitude weighting. 
 
The Image File Generator software cannot generate complex frequency patterns directly e.g. spiral 
shape. However it is possible to use (say) an Excel spreadsheet to generate Frequency values and 
then import these into Image File Generator software. 
 
The example below illustrates the process using three images; Circle, Vertical line and Horizontal 
line.  Lines are generated using frequency values calculated using the inbuilt function generator.  The 
circle data uses imported frequency values.  
 
1: Create one or more Image Files  
 
Press Create Image File and enter file name 
Each file will contain one or many Images.    
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We now need to generate/import the Image data for each Image File. 
  
Highlight the desired Image File e.g. First Image Set 
Press Image Editor button. 
This opens a second window. Note the Tools tab, top left.     
 
2: Set the Displayed Units 
 
Using the Tools tab, select  Tools > Display Preferences 
 
For this example,  select Hex, MHz, % and Degrees  as shown below 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Press OK to update and store selection 
 
3: Create one or more Images 
 
Select Create New Image. 
Enter a name for the first image  e.g. Pattern1 
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Repeated to create Pattern2 and Pattern3 
 
3.1 Enter Image Data 
 
Highlight Pattern1  
 
Enter Number of Channels  using pull down box.    (For an X-Y AOD enter 4) 
Enter Number of Points    (For clarity, less than 25 points are used in the examples) 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
For Pattern1, we will import frequency data from a Spreadsheet that generates a circle pattern for 
 X-Y AO deflector.    
 
Select Tools>Import Data 
Navigate to the required Spreadsheet using Open button  
Select the desired Worksheet tab of the Spreadsheet using the pull down Worksheet  
 
For an X-Y AOD,  
Frequency values for Chan 0 = Chan 1  
Frequency values for Chan 2 = Chan 3 
 
Uncheck the Interleave Channels box 
   
Select Chan 0  tab  
 
Check Frequency box only    
Input the spreadsheet cell reference for the first frequency value (e.g.  Cell Q:2)  
 
Set the Number of Rows to Import  (in this example 20) 
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Repeat all channels 
 
Chan 0 = Chan 1, First Cell = Q2  
Chan 2 = Chan 3, First Cell = R2 
 
 
Click Channel tabs in main window to check values  
 
Press OK to update and store  
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4: Phase values 
 
Next step is to calculate theoretical Phase values at for frequency  
 
Note: The phase values are only correct IF the AOD Bragg angles have been adjusted at the Bragg 
Angle Frequency display below.  This value is set by the user. 
Initial Laser alignment is described in a separate document.  
 
Select Tools> Beam Steering AOD Phase Calculator 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Input Bragg Angle Frequency (Usually set at the AOD centre frequency, 110MHz) 
Input Laser Wavelength (355nm) 
Select AO Crystal Material  (a-Quartz) 
Input AOD Geometric Constant. (The value of 1.9298 is correct for the D1340-XY-aQ110)   
 
Check the Dual Axis X-Y Scanning box 
 
Chan 0 and Chan 2 will always have zero phase values (or 360 deg) 
Chan 1 and Chan 3 will show frequency dependent phase values  
 
 
If frequency values are subsequently changed, the Phase calculator must be run again  
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5: Amplitude values 
 
The final RF amplitude is controlled by a combination of 3 methods described in the illustration 
below. 
 

 

 
 

 
The Image data defines the fundamental value. 
 
For initial operation, this is set at a constant value for all frequencies. 
 
[At a later stage during fine tuning and calibration of the system, these amplitude values may be 
adjusted depending on the frequency.  This is one method, with the aid of an optical power meter, 
to optimize the uniformity across the  X-Y scan field ]  
 
To pre-set amplitude to 75% maximum, all channels 
 
 
Select Tools>Function Generator 

Function pull down, select Linear Interpolation 
Applied to pull down select Amplitude 
Check boxes, Ch 0, Ch 1, Ch 2 and Ch 3 

Set Parameters 
Starting Value  75 % 
Ending Value    75 % 
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Point Range. 
Different sections of the image may be programmed with different amplitude values by changing the 
To and From points. For this example we set the amplitude to be the same for all points of the image 
Thus: 
 
From 1  To  20  
 
Press OK to save and exit Pattern 1 
 
 
6: Highlight Pattern2  
 
For Pattern2, we will use the in-built function generator to create a vertical line midway along the X-
axis.    
 

 Y-axis (scans) 
Select Tools>Function Generator 

Function pull down, select Linear Interpolation  
Applied to pull down select Frequency  
Check boxes, Ch 2 and Ch 3 only 

Set Parameters 
Starting Value  90 MHz 
Ending Value    130 MHz 
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 X-Axis (static) 
Select Tools>Function Generator 

Function pull down, select Linear Interpolation  
Applied to pull down select Frequency  
Check boxes, Ch 0 and Ch 1 only 

Set Parameters 
Starting Value  110 MHz 
Ending Value    110 MHz 

 
 
 
 
 
 
 
Phase values, repeat step 4: above 
Amplitude values, repeat step 5: above 
  
Press OK to save and exit Pattern 2 
 
 
7: Highlight Pattern3  
 
For Pattern3, we will use the in-built function generator to create a horizontal line midway up the  
Y-axis.    
 

 Y-axis (static) 
Select Tools>Function Generator 

Function pull down, select Linear Interpolation  
Applied to pull down select Frequency  
Check boxes, Ch 2 and Ch 3 only 

Set Parameters 
Starting Value  110 MHz 
Ending Value    110 MHz 

 

 X-Axis (scans) 
Select Tools>Function Generator 

Function pull down, select Linear Interpolation  
Applied to pull down select Frequency  
Check boxes, Ch 0 and Ch 1 only 

Set Parameters 
Starting Value  90 MHz 
Ending Value    130 MHz 

 
Phase values, repeat step 4: above 
Amplitude values, repeat step 5: above 
  
Press OK to save and exit Pattern 3 
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8: Sync Control Data 
 
The iHHS-4 can output digital and analog signals synchronously with the frequency data output on 
any of the 4 channels.  This is the Sync Control Data and can be used to synchronize external 
equipment. 
 
In the standard iHHS-4, there are 8 synchronous digital output signals. Each can be set 
independently to output a “High” or “Low” signal. These outputs may also be delayed by a 
predetermined period after the frequency data has changed. This delay option is applied to 
individual bits selected by the user.  
 
The digital outputs can set to give an output Level or Pulsed per data clock (Internal or External). 
This is a global setting for all synchronous digital outputs.   
 
Level = Constant level for the entire clock period 
Pulsed = High level Pulse at ½ clock period 
 
Typically the Sync control data is set on Channel 0 only 
Highlight Channel 0 tab   
 
Sync Control Data pull down, select Sync Digital output  
 
 
 
 
 
 
 
 
 
 
Select Tools>Function Generator 

Function pull down, select Linear Interpolation 
Applied to pull down select Sync Data 
Check box, Ch 0 only 

 
We will set for a pulse to be generated on all 8 outputs at every point of the image  
 
Set Parameters 

Starting Value  0FF  hex 
Ending Value    0FF  hex 

Check the Pulsed radio button  
(Pulse width = 1usec) 
 
Digital outputs are available on Connector J6 
SDIO bit0 = pin18 SDIO bit1 = pin17 
SDIO bit2 = pin16 SDIO bit3 = pin15 
SDIO bit4 = pin14 SDIO bit5 = pin13 
SDIO bit6 = pin12 SDIO bit7 = pin11 
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We will also opt to have a delay applied to four of the lower bits (outputs) 
The delay value is set later in this procedure. 
 
Check the boxes Apply Delay to Sync Digital Out Bits:  0, 1, 2, 3   
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9: Image Control  
 
To complete the Image file format, we need to specify the output control parameters including the 
Clock, Trigger and Sync data parameters for each image in the file. 
 
For this example, the Image File (Image Set 1) contains 3 images; 
 
- Circle of 20 points,  
- Vertical line of 21 points  
- Horizontal line of 21 points. 
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 CLOCK 
The clock rate defines the dwell time at each frequency point of the image. 
 e.g. for an image of 20 points and a clock period of 5usec, the time to complete one play = 100usec    
 
The frequencies at all 4 output channels are updated synchronously. 
 
Select Image Point Clock radio button  
 
Options:  

 Internally generated user programmable clock (see Internal Oscillator Period, page14) 

 External input, LVTTL  pin 19  J6  (see External clock Divider, page14) 
 
e.g.  Internal (clock rate setting is described on page14)   
 

 
 
 

 TRIGGER   
The trigger signal initiates the image output sequence at a rate defined by the CLOCK signal. 
A trigger is required for each separate image in the file set. There are four trigger options;  
 

 After a pre-determined programmable delay (between each image of a multi-image file) 
 

 External input to pin 20  J6,  (one image play per trigger input * ) 
 

 Asynchronous trigger (via software) 
 

 Immediate.  Triggered on the second valid clock input edge 
 
 
Image data output starts two clock cycles after the Trigger input  
 
 
 
 

* External trigger initiates the 
output of one image play. 
Repeated images will require 
repeated triggers. 
Each image in a multi-image 
sequence will require a trigger 
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10: Sequence Editor 
 
Press the Sequence Editor button to reveal a new window. 
   
The Sequence editor defines the play order of images, Repeats (= image play per trigger event), the 
Internal Oscillator Period (= output Clock rate), Sync Data Delay and the Inter–Image delay    
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Image play list  
 
Use pull down (ringed) to select the required Image from the file set. 
 
Add or delete Images into the play list as required, in any order using the New Entry or Delete Entry 
keys respectively.   
 
The order of Play can be changed by highlighting the Image entry and using the Move Up or  
Move Down keys 
 
 
 e.g.  
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Select desired Image e.g. Pattern1 
 
Four variables can be set for each image trigger event 
 
Repeat:  0-255 
 The Image data can be output multiple times in succession per trigger event 
(Note: 8 repeats means Pattern1 is output 9 times for each trigger). 

 
Sync Data Delay:  0.0 - 6500.0usec, resolution 0.1usec 
A delay can be set between the Sync Data Output and the corresponding Frequency update clock. 
 
Internal Oscillator Period: 1 - 65000usec, resolution 1usec 
If the internal clock is selected, this value defines the frequency point update period 
 e.g. 8usec = 125KHz output rate 
 
(If the external clock is selected, this value defines the external clock divider) 
  
Inter Image Delay: 0.0 - 6500.0millisec, resolution 0.1millisec 
Sets a delay value between end of Image N and start of Image N+1 
 
Repeat for all images in the play list. All values can be different. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
A Sequence Termination Actions MUST be select 
  
This instructs the iHHS-4 what action to take once the triggered sequence has completed   
 
Select the required action from the Sequence Termination Action pull down  
e.g. Repeat Entire Sequence at the  next Trigger event 
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The INDEX pointer allows a different start image to be selected if the sequence is to be repeated. 
If STOP is selected, then your will need to Hit Run on the iHHS Tool software to arm the system for 
each Trigger event. 
 
Press OK to save and exit 
 
We have now created a combined Image and Sequence File in the correct format for the iHHS-4 
“Image Mode”. This needs to be Exported and Saved in a location available to the iHHS-4 control 
software.  
  
 
Select Export Image File   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Enter file name e.g. spiralshape.ihh and press Save 
 
11: Saving the Project 
 
Prior to exiting the software, the entire project can be saved using File>Save  
File extension *.iip 
 


